PAT--甲 1050 String Subtraction

甲 1050 String Subtraction (题解)

Given two strings S1 and S2, S = S1 - S2 is defined to be the remaining string after taking all the characters in S2 from S1. Your task is simply to calculate S1 - S2for any given strings. However, it might not be that simple to do it fast.

输入信息:

Each input file contains one test case. Each case consists of two lines which gives S1 and S2, respectively. The string lengths of both strings are no more than 104. It is guaranteed that all the characters are visible ASCII codes and white space, and a new line character signals the end of a string.

输出信息:

For each test case, print S1 - S2 in one line.

样例输入:

1
2
They are students.
aeiou

样例输出:

1
Thy r stdnts.

思路:运用哈希函数,将s2中出现的字符标志设置为true,在s1中遍历,将为false的字符输出。

注意:

1.多层循环嵌套会导致运行超时

2.注意字符串的范围,会导致RE60%

代码如下:

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
#include <stdio.h>
#include <string.h>
bool H[26];
int main()
{
char a[10100],b[10100];
gets(a);
gets(b);
int la=strlen(a);
int lb=strlen(b);
for(int i=0;i<lb;i++) //在字符串b中出现,设置标志位为true.
H[b[i]]=true;
for(int i=0;i<la;i++)
if(H[a[i]]==false) //标志位为false,输出该字符
printf("%c",a[i]);
printf("\n");
return 0;
}
小礼物走一个哟
0%